Overview
Sometimes Hoxhunt button might not appear in your Outlook email client. This article contains the most common causes for issues with the Hoxhunt button in Outlook with the COM add-in and helps you and your IT support to find a solution. Hoxhunt's legacy COM add-in is easy to use but can still generate errors. This article aims to help you analyse the root causes for any problem and how to resolve them.
If you are unsure which Hoxhunt button (add-in, add-on) you have in use, check out: Identifying installed Hoxhunt button (add-in / add-on type)
If you are using the Office add-on, please refer to this troubleshooting guide: Troubleshooting missing Hoxhunt button in Outlook Office add-in
DISCLAIMER: Hoxhunt is not actively developing this add-in type. It is lacking many features and is more simplistic in its design. Before installing this version, we highly recommend to consider our Office add-in which is based on Microsoft's modern Office add-in architecture.
Content list
Navigate to specific topics in this article below:
Hoxhunt button is missing from my Outlook for Desktop (Windows)
- Error: Welcome to HoxHunt error
- Error: Reporting failed, could not connect to Hoxhunt servers
- Error: Reporting failed to create the temporary file
- Error: Please select an email first
- Error: Custom UI Runtime Error in Hoxhunt Plugin
- Error: Webpage Error
General triage questions and steps for Helpdesks
Hoxhunt button is missing from my Outlook for Desktop (Windows)
Make sure the Hoxhunt button has not been disabled in File > Options > Add-ins. From the Manage dropdown list at the bottom select COM Add-ins and click Go... Make sure the checkbox next to Hoxhunt Report add-in has been ticked.
Hoxhunt button errors
Error: Welcome to HoxHunt error
Symptom
Welcome to HoxHunt
You should complete the onboarding first before you can report any emails.
If you have not yet received an invite from us, we will send one soon.
Explanations and resolutions
For all below, please contact Hoxhunt Support for assistance at support@hoxhunt.com.
Option #1: You must first report a Hoxhunt email before you can use Hoxhunt add-in to report other suspicious emails.
Option #2: Hoxhunt training might have been paused for you.
Option #3: Your Hoxhunt user account might have been removed and re-created.
Option #4: Your email address has changed. Hoxhunt Support must send you a new simulation to re-link you to the system.
Option #5: You have switched to a new computer. Hoxhunt Support must send you a new simulation to re-link you to the system.
Error: Reporting failed, could not connect to Hoxhunt servers
Symptom
Error
Reporting failed, could not connect to HoxHunt servers.
Are you connected to the Internet?
If the problem persists please contact support@hoxhunt.com.
Possible root causes
There are multiple potential possible causes for this generic error message:
- Hoxhunt add-in wasn't uninstalled and re-installed when computer was given to another employee
- Training email was already reported earlier
- The training emails was originally sent for another Hoxhunt user
- User's mail server address is not configured to Hoxhunt system
- Networking issue
Explanation and solution
Hoxhunt add-in wasn't uninstalled and re-installed when computer was given to another employee
- User is using Hoxhunt on a computer that used to belong to a another Hoxhunt user.
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All devices where COM add-in is installed get assigned their own unique Plugin ID upon installation. When a user first reports using the new device, the Plugin ID is linked to the user’s Hoxhunt account.
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The COM add-in installation is bound to the user as long as the user exists in the system.
-
Therefore, if a computer with Hoxhunt COM add-in is given to another Hoxhunt user, the new user can’t report any Hoxhunt training emails with the COM add-in.
- Open Registry Editor (regedit.exe).
- Look for your Hoxhunt userGuid from following registry path:
HKEY_CURRENT_USER\SOFTWARE\Hoxhunt - Give the value for userGuid entry to Hoxhunt Support. It looks similar to this:
a782fd7d-abc3-498f-8d12-e5cd33f44f9a
Training email was already reported earlier
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Are you reporting an older email that was sent to your previous Hoxhunt user account? If a user is deleted and re-created in the Hoxhunt service, and the user then tries to re-report the old email, it might fail like this. This can occur to users who were part of Hoxhunt's technical testing during onboarding.
- Delete the email or contact Hoxhunt Support.
The training email was originally sent for another Hoxhunt user
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If a user has two email addresses, they might get this error. Please check the user's training statistics for both email addresses. You may discover that the training email was sent to user A but Hoxhunt add-in was deployed to user B and the reporter is user B.
User's mail server address is not configured in the Hoxhunt system
- Please contact Hoxhunt Support (support@hoxhunt.com).
Networking issue
- Is there a working Internet connection?
- Have the firewall rules for allowed domains changed? Make sure *.hoxhunt.com traffic is allowed.
- Is there a new antivirus or network solution on the local desktop that blocks un-allowed traffic? (Antivirus, firewall, VPN solution, etc.).
- Hoxhunt COM add-in is using TLS1.0 encryption instead of TLS1.1 or higher (see below)
NOTE about applications targeting .NET 4.5.2 and TLS version support
Hoxhunt COM add-in targets .NET framework version 4.5.2 even if you have installed a more recent version such as .NET 4.7.
As .NET 4.5.2 defaults to TLS1.0 unless otherwise specified by the application, if client computer still has TLS1.0 allowed, Hoxhunt COM add-in will use TLS1.0.
If you have blocked TLS1.0 traffic in your firewall, Hoxhunt COM add-in will throw a connectivity-related error.
To make sure Hoxhunt COM add-in uses TLS1.1 or higher, we recommend to disable TLS1.0 on the client computer and enforce Strong Crypto according to Microsoft's article: https://learn.microsoft.com/en-us/dotnet/framework/network-programming/tls
IMPORTANT: These registry changes will affect all your .NET framework based applications that still rely on TLS1.0! Please consult your IT before performing any changes.
Please contact Hoxhunt Support with any questions regarding the TLS encryption.
Error: Reporting failed to create the temporary file
Symptom
HoxHunt
Reporting failed to create the temporary file.
Try again or contact support@hoxhunt.com.
Explanation
COM add-in temporarily saves the email as .eml to Temp folder before uploading it to Hoxhunt.
This error occurs if add-in doesn’t have permissions to write to user’s Temp folder. (%USERPROFILE%\AppData\Local\Temp)
Error: Please select an email first
Symptom
HoxHunt
Please select an email first
Explanation
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Option 1: The reported email is a Hoxhunt simulation but it is addressed to another Hoxhunt user. Please check if one of you colleagues is forwarding their email to you.
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Option 2: The simulation was deleted from Hoxhunt side and is thus not recognized. Please delete the email or contact Hoxhunt Support for assistance.
Error: Custom UI Runtime Error in Hoxhunt Plugin
Symptom
User receives one of the following error messages.
Custom UI Runtime Error in HoxHunt Plugin
Error found in Custom UI XML of "HoxHunt Plugin":
Line: 3
Column: 37
Error Code: 0x80004005
Failed to find Office Control by ID
ID: TabReadMessage
Custom UI Runtime Error in HoxHunt Plugin
Error found in Custom UI XML of "HoxHunt Plugin":
Line: 3
Column: 37
Error Code: 0x80004005
Failed to find Office Control by ID
ID: TabMail
Explanation
The error is displayed if Outlook > Options > Options > Show add-in user interface errors is enabled in Outlook.
Root cause
Currently (07/2019, 07/2020) the add-in is looking for TabMail and TabReadMessage in both views where the button is located, and this causes the errors. To our knowledge this only occurs for Outlook 2010 users.
Workaround
Untick the setting and the issue goes away. As the “Show add-in user interface errors” is off by default, it shouldn’t be too visible for majority of users.
While the technical functionality of the add-in itself is not degraded, we will provide a fix for it in our future build.
Error: Webpage Error
Symptom
When launching Outlook an error is displayed:
Webpage error
Error: 'console' is undefined
A Runtime error has occurred
Do you want to debug this webpage?
Explanation
The error is caused by enabled script debugging feature in Internet Explorer settings.
Workaround
- Internet Explorer: Tools > Internet Options > Advanced
- Tick Disable script debugging (Internet Explorer)
- Tick Disable script debugging (Other)
- Untick Display a notification about every script error
More information
https://support.microsoft.com/en-us/help/822521/fix-runtime-errors-in-internet-explorer
General triage questions and steps for Helpdesks
1) Does the error occur when user opens email to a separate window?
- Please explain what steps lead to the error message to appear.
2) When the error occurs, is the standard "Message" tab still visible in Home view and when email is opened to a separate window?
- Hoxhunt button is designed to display on the general Message tab instead of a dedicated tab for easy access. If there is a callback conflict caused by Hoxhunt add-in or some other add-in, it may hide Message tab completely. In this case it sounds like Hoxhunt add-in is unable to locate the Message tab in the first place, indicating that either Hoxhunt add-in or some other add-in is causing a callback conflict and thus hiding Message tab.
3) When the error occurs, is Hoxhunt button still visible?
- do other add-ins go missing at the same time?
- Please check File > Options > Add-ins if any COM add-in have been disabled.
- If there is a conflict between any of the add-ins, they might start causing trouble to each other. Try disabling all add-ins and enable them one by one and restart Outlook after each step. You should be able to pinpoint when the error starts to re-occur.
- Reference: https://social.microsoft.com/Forums/security/ro-RO/6a0d264f-cf81-4f55-baaf-b99b335a858d/quotmessagequot-tab-missing-in-outlook-ribbon-tabreadmessage?forum=outlookdev
4) Disable add-in interface errors
- Multiple things can go wrong when VSTO/COM add-ins are initialised. Usually the errors are non-critical but they can generate functional issues if user interface errors have been enabled in settings. The setting is mainly targeted for developers and is not normally enabled for end users.
- Go to File > Options > Advanced.
- Under General section, uncheck Show add-in user interface errors.
- (Note: the option might be located under Developer section instead of General section)
- Let Hoxhunt Support know if the error went away but other functional issues still occur. Also let us know if the error went away and no other functional issues occur anymore.
- Reference: https://docs.microsoft.com/fi-fi/visualstudio/vsto/how-to-show-add-in-user-interface-errors?redirectedfrom=MSDN&view=vs-2019
- Reference: https://support.microsoft.com/en-us/office/view-manage-and-install-add-ins-in-office-programs-16278816-1948-4028-91e5-76dca5380f8d
5) Reset Ribbon customizations and Quick Access Toolbar
- Sometimes resetting Ribbon customisation may help but if there are many customisations, it needs to be done in a careful fashion so you don't "over reset" user's ribbons.
- Go to File > Options > Ribbon. In Customize the Ribbon, under Customizations, Reset > Reset all customizations. Alternatively, try to locate the Message Ribbon under Main Tabs.
- Go to File > Options > Quick Access Toolbar. In the Customize the Quick Access Toolbar window, click Reset Defaults, and then click Reset only Quick Access Toolbar.
- Reference: https://support.microsoft.com/en-us/office/customize-the-ribbon-in-office-00f24ca7-6021-48d3-9514-a31a460ecb31
- Reference: https://support.microsoft.com/en-us/office/customize-the-quick-access-toolbar-43fff1c9-ebc4-4963-bdbd-c2b6b0739e52
Questions or further issues?
If you need any additional help, please don't hesitate to reach out to Hoxhunt Support at support@hoxhunt.com